Die Mathe-Redaktion - 22.06.2018 05:15 - Registrieren/Login
Auswahl
ListenpunktHome
ListenpunktAktuell und Interessant ai
ListenpunktArtikelübersicht/-suche
ListenpunktAlle Links / Mathe-Links
ListenpunktFach- & Sachbücher
ListenpunktMitglieder / Karte
ListenpunktRegistrieren/Login
ListenpunktArbeitsgruppen
ListenpunktSchwätz / Top 15
ListenpunktWerde Mathe-Millionär!
ListenpunktAnmeldung MPCT Juli
ListenpunktFormeleditor fedgeo
Schwarzes Brett
Aktion im Forum
Suche
Stichwortsuche in Artikeln und Links von Matheplanet
Suchen im Forum
Suchtipps

Bücher
Englische Bücher
Software
Suchbegriffe:
Mathematik bei amazon
Naturwissenschaft & Technik
In Partnerschaft mit Amazon.de
Kontakt
Mail an Matroid
[Keine Übungsaufgaben!]
Impressum

Bitte beachten Sie unsere Nutzungsbedingungen, die Distanzierung, unsere Datenschutzerklärung und
die Forumregeln.

Sie können Mitglied werden. Mitglieder können den Matheplanet-Newsletter bestellen, der etwa alle 2 Monate erscheint.

Der Newsletter Okt. 2017

Für Mitglieder
Mathematisch für Anfänger
Wer ist Online
Aktuell sind 197 Gäste und 3 Mitglieder online.

Sie können Mitglied werden:
Klick hier.

Über Matheplanet
 
Zum letzten Themenfilter: Themenfilter:
Matroids Matheplanet Forum Index
Moderiert von mire2 gaussmath
Mathematische Software & Apps » Andere Softwarepakete » wxMaxima zeigt keine ausgewerteten Zeilen an
Druckversion
Druckversion
Autor
Kein bestimmter Bereich J wxMaxima zeigt keine ausgewerteten Zeilen an
shadowking
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 04.09.2003
Mitteilungen: 3422
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Themenstart: 2018-05-17


Hallo,

wer nutzt wxMaxima auf einer neueren Linux-Mint-Distribution? Da ich vor einigen Wochen einen neuen Rechner bekommen habe, habe ich auf Version 18.3 upgedatet und wollte natürlich auch mein Lieblings-CAS, wxMaxima, weiter nutzen. Da tritt in der Version 15.08.2 das Problem auf, daß nach Eingabe etwa von "1+1" nicht das Ergebnis "2" erscheint, wenn man die Zeile auswertet, sondern gar nichts passiert. Mit den in der Menüzeile angebotenen Hilfen bekomme ich das Problem nicht in den Griff. Ich möchte aber doch bei einer Rechenoperation ein Ergebnis angezeigt bekommen.

Ich hatte das Problem schon einmal und habe es wundersamerweise dadurch gelöst bekommen, dass ich eine oder einige Dateien aus der bisherigen Linux-Installation (17.1) in die neue kopierte. Allerdings habe ich mir nicht gemerkt, welche Dateien das waren oder wo diese gespeichert waren, und diese Linux-Installation besteht auch inzwischen nicht mehr, da ich die Festplatte, auf der sie sich befand, mittlerweile formatiert habe. Es steht allerdings noch eine Linux-Mint-13-Installation auf einer virtuellen Maschine zur Verfügung, aus der Dateien und Ordner exportiert werden könnten.

Nun musste ich die Version 18.3 heute früh neu installieren. Mit dem Sicherungswerkzeug konnte ich die Softwareauswahl recht zügig wiederbekommen, aber das alte Problem mit wxMaxima ist wieder da.

Ich hoffe, jemand versteht, was ich damit meine, und kann mir eventuell helfen. Ein anderer Tipp, eventuell wie man an eine vorherige Version des Programms kommt, in der dieses Problem nicht auftritt, wäre auch hilfreich.

Gruß shadowking


-----------------
Niemand ist hoffnungsloser versklavt als der, der fälschlich glaubt frei zu sein.
- Johann Wolfgang von Goethe




  Profil  Quote  Link auf diesen Beitrag Link
AlphaSigma
Aktiv Letzter Besuch: in der letzten Woche
Dabei seit: 23.11.2012
Mitteilungen: 142
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.1, eingetragen 2018-05-18


Hallo shadowking,

zu wxmaxima unter Linux-Mint direkt kann ich nichts sagen.
Ich nutze maxima 5.38.1 unter Debian 9 (stretch) und
da werden Terme, die mit ';' enden, ausgegeben:
(%i1) 1+1;
(%o1)                                  2
(%i2)

Unter Debian 9 ist übrigens 16.04.2-1 die aktuelle Version von wxmaxima.
Hast Du nach "1+1" auch ein Semikolon eingegeben?



  Profil  Quote  Link auf diesen Beitrag Link
schnitzel
Aktiv Letzter Besuch: in der letzten Woche
Dabei seit: 26.02.2009
Mitteilungen: 112
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.2, eingetragen 2018-05-18


Hi,
also ich hab die gleichen Versionen (Mint, wxmaxima) und es funktioniert. (Man muss mit Shift Enter ausführen.) Die ppa Versionen sind manchmal aktueller, vlt. hilft das ja.
Gruß



  Profil  Quote  Link auf diesen Beitrag Link
shadowking
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 04.09.2003
Mitteilungen: 3422
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.3, vom Themenstarter, eingetragen 2018-05-19


Ich habe alles ausprobiert: Dateien aus älteren Versionen in den Ordner der aktuellen kopiert, Eingaben mit Semikolon abschließen und auch die Einstellung auf "'Enter' wertet Zeile aus" ändern und wieder zurück auf 'Umschalten + Enter'. Nichts hat geholfen. Mir fällt auch auf, dass ich jedesmal die Toolbar wieder zuschalten muss, da sie standardmäßig beim Programmstart ausgeschaltet ist.

Im ganzen Internet finde ich zudem keine Diskussionen über ein solches Verhalten von wxMaxima: nicht auf Englisch, nicht auf Deutsch und auch nicht auf Spanisch. Entweder habe ich nicht richtig oder nicht intensiv genug gesucht, oder ich bin die einzige Person, bei der dieses Problem auftritt.

In meinem persönlichen Ordner habe ich einige Dateien gefunden, die das Datum von heute tragen, z.B. ein "maxout.png" mit dem Graphen einer Funktion, die ich in wxMaxima testweise hatte plotten wollen. Es liegt also ein Fehler in wxMaxima vor, nicht in Maxima, das die Eingaben verarbeitet hat.

Ich würde mittlerweile auch eine andere als die über die Anwendungsverwaltung bereitgestellte Version installieren, bräuchte dafür aber genaue Angaben, was ich in der Kommandozeile auszuführen habe. Versucht habe ich dieses hier: launchpad.net/~blahota/+archive/ubuntu/wxmaxima, was aber an der Unfähigkeit scheiterte, einen GPG-Schlüssel zu laden.

Ich weiß nicht mehr weiter und werde bis auf weiteres das wxMaxima in der virtuellen Maschine nutzen, das noch älter als 15.08.2 (nämlich 11.08.0) ist.

Danke für Euer Interesse, shadowking


-----------------
Niemand ist hoffnungsloser versklavt als der, der fälschlich glaubt frei zu sein.
- Johann Wolfgang von Goethe




  Profil  Quote  Link auf diesen Beitrag Link
schnitzel
Aktiv Letzter Besuch: in der letzten Woche
Dabei seit: 26.02.2009
Mitteilungen: 112
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.4, eingetragen 2018-05-19


Hi, was mir sonst noch einfällt:
- schauen ob maxima kaputt ist: einfach mal maxima in der Konsole ausführen.
 Ich hab da Version 5.37.2

- schauen ob die config Datei komisch aussieht: normalerweise sowas wie .wxmaxima im home Verzeichnis

- es gibt Möglichkeiten Maxima in anderen Notebooks laufen zu lassen. Z.B. Cantor oder Jupyter Notebook

Hast du die ppa nun in deine Aktualisierungsverwaltung eingetragen?
Gruß



  Profil  Quote  Link auf diesen Beitrag Link
shadowking
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 04.09.2003
Mitteilungen: 3422
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.5, vom Themenstarter, eingetragen 2018-05-21


Jawoll, jetzt läuft es! Vielen Dank an schnitzel für den Tipp mit der Aktualisierungsverwaltung. Darüber konnte ich jetzt die Installation der Blahota-Version von wxMaxima (18.02.0) erzwingen, und die hat das Anzeigeproblem nicht.

Es lag übrigens kein Problem mit Maxima selbst vor, das funktioniert problemlos über die Befehlszeile (man muss allerdings Eingaben immer mit ";" abschließen, wenn man sie ausgewertet sehen will).

Eine Frage noch. Wenn man versehentlich die Anzeigeschriftart geändert hat, wie kann man wieder zum Default zurückkehren? Oder äquivalent: Wie heißt die als Default verwendete Schrift? Im Auswahlfeld steht standardmäßig "Schriftart wählen", aber nicht die als Default verwendete Schriftart.

Gruß shadowking


-----------------
Niemand ist hoffnungsloser versklavt als der, der fälschlich glaubt frei zu sein.
- Johann Wolfgang von Goethe




  Profil  Quote  Link auf diesen Beitrag Link
schnitzel
Aktiv Letzter Besuch: in der letzten Woche
Dabei seit: 26.02.2009
Mitteilungen: 112
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.6, eingetragen 2018-05-26 11:10



 Wie heißt die als Default verwendete Schrift?

Also bei mir ist da Sans Regular drin.
Gruß



  Profil  Quote  Link auf diesen Beitrag Link
shadowking
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 04.09.2003
Mitteilungen: 3422
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.7, vom Themenstarter, eingetragen 2018-05-28 23:30


Sans Regular habe ich auch; dann ist das möglicherweise doch nicht durch eine Aktion meinerseits so. Ich beobachte jedenfalls bei dieser Schriftart öfters ein Überlappen: einerseits zwischen Koeffizienten und Variablen bei Polynomen, wenn die Koeffizienten mehr als ca. 10-stellig sind, und andererseits, wenn das System Fragen stellt wie: "Is p-1 positive, negative, or zero?", zwischen Frage und einzugebender Antwort. Ich glaube, ich probiere mal ein paar Schriften mit gleichmäßiger Buchstabenbreite aus, bis das nicht mehr auftritt.

Gruß



  Profil  Quote  Link auf diesen Beitrag Link
shadowking
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 04.09.2003
Mitteilungen: 3422
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.8, vom Themenstarter, eingetragen 2018-05-28 23:38


Bei Monospace Regular tritt dies nicht auf; das habe ich jetzt eingestellt.

Vielen Dank, besonders an schnitzel. Ich hake dann mal ab.


-----------------
Niemand ist hoffnungsloser versklavt als der, der fälschlich glaubt frei zu sein.
- Johann Wolfgang von Goethe




  Profil  Quote  Link auf diesen Beitrag Link
shadowking hat die Antworten auf ihre/seine Frage gesehen.
shadowking hat selbst das Ok-Häkchen gesetzt.
Neues Thema [Neues Thema]  Druckversion [Druckversion]

 


Wechsel in ein anderes Forum:
 Suchen    
 
All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © 2001-2018 by Matroids Matheplanet
This web site was made with PHP-Nuke, a web portal system written in PHP. PHP-Nuke is Free Software released under the GNU/GPL license.
Ich distanziere mich von rechtswidrigen oder anstößigen Inhalten, die sich trotz aufmerksamer Prüfung hinter hier verwendeten Links verbergen mögen.
Lesen Sie die Nutzungsbedingungen, die Distanzierung, die Datenschutzerklärung und das Impressum.
[Seitenanfang]