Matroids Matheplanet Forum Index
Moderiert von matroid Gockel
Matheplanet » Bug- und Request-Tracker » Persönliches Menü beim Abspeichern zerschossen
Druckversion
Druckversion
Autor
Kein bestimmter Bereich J Persönliches Menü beim Abspeichern zerschossen
Bernhard
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 01.10.2005
Mitteilungen: 6301
Aus: Merzhausen, Deutschland
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Themenstart: 2020-01-22


Hallo!

Ich hatte mir schon lange mit der älteren Methode ein persönliches Menü auf meinem Account erstellt und auch die Einträge mit HTML ganz nach meiner Facon formatiert. Eben will ich daran etwas verändern (einen Link aktualisieren). Nach dem Abspeichern sind die Einträge vollständig anders formatiert und die Links funktionieren auch nicht mehr. Im HTML-Code sind automatisch und ganz willkürlich überall Schrägstriche (\\\) eingestreut worden.
Aus ehemals
HTML
<a
 href="viewforum.php?forum=7"
 target="_self"><b><font color="#d2691e">Spiel und Spaß</font></b></a>
ist jetzt das geworden:
HTML
<a
 href=\\\"viewforum.php?forum=7\\\"
 target=\\\"_self\\\"><b><font color=\\\"#d2691e\\\">Spiel und Spaß</font></b></a>
Einmal habe ich die Striche mühsam wieder herausgelöscht und den Code dann auch anderswo abgespeichert, denn als ich ihn wieder in dem Feld von den Seiteneinstellungen abspeichern wollte, waren die Striche wieder da.

Wie kann das kommen? Bisher hatte ich damit noch keine Probleme.

Viele Grüße, Bernhard


-----------------
"Wichtig ist, daß man nie aufhört zu fragen"
"Weisheit ist nicht das Ergebnis der Schulbildung, sondern des lebenslangen Versuches, sie zu erwerben"
Albert Einstein



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
zippy
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.10.2018
Mitteilungen: 1405
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.1, eingetragen 2020-01-22


Als Workaround kannst du die Anführungszeichen einfach weglassen. Es funktioniert beispielsweise:
HTML
<a
 href=viewforum.php?forum=7
 target=_self><b><font color=#d2691e>Spiel und Spaß</font></b></a>

--zippy



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
matroid
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 12.03.2001
Mitteilungen: 14264
Aus: Solingen
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.2, eingetragen 2020-01-22


Hallo Bernhard,

ich habe es korrigiert. Bitte versuche es jetzt noch einmal.

Gruß
Matroid



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
zippy
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.10.2018
Mitteilungen: 1405
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.3, eingetragen 2020-01-22


Es funktioniert noch nicht.

Der Code
HTML
<a
 href="viewforum.php?forum=7"
 target="_self"><b><font color="#d2691e">Spiel und Spaß</font></b></a>
lässt sich zwar unverändert abspeichern, aber im Menü tauchen wieder unerwünschte quotierte Anführungszeichen auf:
HTML
<div class="sideleft">
  <a href="\"viewforum.php?forum=7\"" target="\"_self\"">
    <b><font color="\"#d2691e\"">Spiel und Spaß</font></b>
  </a>
</div>



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
matroid
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 12.03.2001
Mitteilungen: 14264
Aus: Solingen
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.4, eingetragen 2020-01-22


@zippy: Danke für den Test. Ist es jetzt ok?

Gruß
Matroid



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
zippy
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.10.2018
Mitteilungen: 1405
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.5, eingetragen 2020-01-22


Ja.



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Bernhard
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 01.10.2005
Mitteilungen: 6301
Aus: Merzhausen, Deutschland
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.6, vom Themenstarter, eingetragen 2020-01-24


Hallo zippy und matroid!

Ich habe es jetzt auch ausprobiert und es funktioniert wieder prima wie früher auch. Ich hatte zuerst befürchtet, ich müßte das wieder ganz neu entwerfen - mit allen Formatierungen.

Vielen Dank für die "sachdienlichen Hinweise" und das Testen durch zippy (ich hatte überhaupt nicht bemerkt, daß das etwas mit den Anführungszeichen zu tun hatte!) und natürlich die schnelle Reparatur durch matroid. Ich habe irgendwie den Eindruck, das geht nur bei Formel-1-Reifen schneller… 😄

Viele Grüße, Bernhard


-----------------
"Wichtig ist, daß man nie aufhört zu fragen"
"Weisheit ist nicht das Ergebnis der Schulbildung, sondern des lebenslangen Versuches, sie zu erwerben"
Albert Einstein



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Bernhard hat die Antworten auf ihre/seine Frage gesehen.
Bernhard hat selbst das Ok-Häkchen gesetzt.
Bernhard wird per Mail über neue Antworten informiert.
Neues Thema [Neues Thema]  Druckversion [Druckversion]

 


Wechsel in ein anderes Forum:
 Suchen    
 
All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © 2001-2020 by Matroids Matheplanet
This web site was originally made with PHP-Nuke, a former web portal system written in PHP that seems no longer to be maintained nor supported. PHP-Nuke is Free Software released under the GNU/GPL license.
Ich distanziere mich von rechtswidrigen oder anstößigen Inhalten, die sich trotz aufmerksamer Prüfung hinter hier verwendeten Links verbergen mögen.
Lesen Sie die Nutzungsbedingungen, die Distanzierung, die Datenschutzerklärung und das Impressum.
[Seitenanfang]