Matroids Matheplanet Forum Index
Moderiert von matph
Informatik » Programmieren » Vielfältige SVG-Animierung
Autor
Kein bestimmter Bereich J Vielfältige SVG-Animierung
Goswin
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 18.09.2008
Mitteilungen: 1767
Wohnort: Chile, Ulm
  Themenstart: 2021-11-16

In möchte ein SVG-Element animieren, indem das Attribute "transform" type "rotate" mehrere Werte annimmt. Laut Spezifikation sollte das mit einem animateTransform-Attribut values = "wkl1; wkl2; wkl3" möglich sein, aber ich verstehe die Internet-Erklärungen darüber offenbar nicht. NACHTRAG 1: In Betrag 3 befindet sich ein codierter Testfall, der leider nicht funktioniert. NACHTRAG 2: Fehler gefunden, siehe dort!


   Profil
haegar90
Aktiv Letzter Besuch: im letzten Quartal
Dabei seit: 18.03.2019
Mitteilungen: 935
  Beitrag No.1, eingetragen 2021-11-16

Hallo Goswin, vielleicht findet sich hier etwas.


   Profil
Goswin
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 18.09.2008
Mitteilungen: 1767
Wohnort: Chile, Ulm
  Beitrag No.2, vom Themenstarter, eingetragen 2021-11-16

Danke, haegar90, aber dein "animateMotion-rotate" hat wenig mit dem "animateTransform-rotate" zu tun. Jedenfalls habe ich die htmlself-Seite und die MDN-Seite erst einmal abgespeichert. Aber mein Problem ist ja wohl, dass ich die Anweisungen dort offenbar falsch verstehe oder falsch umsetze. Sollte es etwas mit dem Startmechanismus zu tun haben? Wie starte ich eine Animation von einer Funktion aus? Etwas wie "ID.attr('begin',"start_bt.click");" taugt nicht,da die Funktion sowohl vor als auch nach der Animation Start einiges zu erledigen hat. Das ganze muss *streng synchron* ablaufen.


   Profil
Goswin
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 18.09.2008
Mitteilungen: 1767
Wohnort: Chile, Ulm
  Beitrag No.3, vom Themenstarter, eingetragen 2021-11-17

Weiß jemand, warum folgendes nicht funktioniert? ("Lösung" 😃 unten) \sourceon html/svg/js/jquery \numberson drehtest


\sourceoff Fehler endlich gefunden: Zeile 50 erzeugt einen String mit doppelten Anführungsstrichen, also ≫values = ""20; -30; 0;""≪ anstelle von ≫values = "20; -30; 0;"≪, was bei einem alert leider nicht klar angezeigt wird.



   Profil
Goswin hat die Antworten auf ihre/seine Frage gesehen.
Goswin hat selbst das Ok-Häkchen gesetzt.

Wechsel in ein anderes Forum:
 Suchen    
 
All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © 2001-2022 by Matroids Matheplanet
This web site was originally made with PHP-Nuke, a former web portal system written in PHP that seems no longer to be maintained nor supported. PHP-Nuke is Free Software released under the GNU/GPL license.
Ich distanziere mich von rechtswidrigen oder anstößigen Inhalten, die sich trotz aufmerksamer Prüfung hinter hier verwendeten Links verbergen mögen.
Lesen Sie die Nutzungsbedingungen, die Distanzierung, die Datenschutzerklärung und das Impressum.
[Seitenanfang]